Polaris: Issue - I Cannot Attach, Transfer, or Upload a File

Polaris: Issue - I Cannot Attach, Transfer, or Upload a File

 
Issue:

I am unable to attach, transfer, or upload a file to my account.


Cause:

This is usually caused by having used up the available disk space for your account. Student Polaris accounts have a default quota of 10MB. If you reach your quota and attempt to transfer a file to your account, you will receive an error and may see your files with a file size of zero.

To display your disk quota information, SSH to Polaris and type quota -v at the system prompt. You will see something like this:

Polaris> quota -v

Filesystem
/users/student

usage

quota

limit

timeleft

files

quota

limit

timeleft

 


3367

4000

5000

 


32

0

0

 


In the above example, the user is using 3367 kilobytes (approximately 3.3 megabytes) out of 4000 kilobytes (4 megabytes) permitted. If the user uses more than the value specified in the quota field, she will begin to receive warning messages, however she can temporarily exceed her quota up to the value listed in the hard limit field (5 megabytes in this example).

For additional information on the use of the quota command, type man quota at the Polaris prompt.


Solution:

If you are near your quota, you should delete files you no longer need.

Temporary Storage

If you get a disk space quota error message, you can save the file in the /tmp directory, which is a directory that is available to all users for temporarily storing files that will not fit in their accounts. Files in the /tmp directory are automatically removed after three days or when the system is rebooted (whichever comes first, although reboots are very rare).