Lumen Mastery: Browser Configurations


To ensure that the Lumen Mastery course materials functions properly, please find the recommended browser configurations below: 
 

1.  Use the latest version of your browser
 
         a.  Chrome 44.0 (recommended)
         b.  Firefox 40.0   (recommended)
         c.  Safari 8.0
         d.  Internet Explorer 11

 2.  Set your browser to allow cookies